Blog

Blog > Packages debian/ubuntu pour Rivendell 2.1.4

le 25 Jun 2012

Rivendell 2.1.4

Les paquets de Rivendell 2.1.4 pour Debian and Ubuntu sont maintenant disponibles sur le dépôt Debian Tryphon pour :

Les plateformes i386 et amd64 sont, comme toujours, supportées.

Support de Oneiric & Precise

Les problèmes avec la libraire Qt sous Oneiric et Precise sont maintenant corrigés.

Les paquets de Rivendell sont donc maintenant disponibles pour Oneiric et la dernière LTS (Long Term Support) en date : Precise.

Retrait de Qt3

Rivendell utilise encore la version 3 de Qt (une librarie pour “gérer les fenetres et les boutons”). Cette (vieille) version n’est malheureusement plus supportée par Debian et ne sera pas présente dans la prochaine version stable de Debian (wheezy).

La première conséquence est que Rivendell n’est plus disponible sur Debian unstable/sid car Qt3 n’y est déjà plus présent.

Nous sommes à la recherche d’une solution.

Installation

Vous pouvez obtenir un Rivendell fonctionnel en quelques minutes :

Etape 1 : Ajoutez le dépôt Debian Tryphon à vos sources Debian/Ubuntu

Etape 2 : Installez un serveur MySQL : sudo apt-get install mysql-server

Etape 3 : Installez à la fois Rivendell “server” et “station” : sudo apt-get install rivendell-server rivendell

Etape 4 : Ajoutez l’utilisateur qui doit utiliser Rivendell dans le groupe du même nom. Par exemple, pour vous ajouter vous-même : sudo adduser $USER rivendell

Au passage, vérifiez que le même utilisateur est indiqué dans /etc/rd.conf à la ligne AudioOwner. Si vous utilisez sudo pour l’installation, cela sera le cas. Cette information sera bientôt (à nouveau) paramétrable à l’installation.

Etape 5 : Quittez et relancez votre session (Gnome, KDE, etc …) pour prendre en compte le nouveau groupe et les permissions données au groupe rivendell lors de l’installation

Etape 6 : Lancez rdadmin qui va créer la base en vous demandant le login de l’administrateur MySQL (root) et le mot de passe (choisi pendant l’installation de mysql-server).

Etape 7 : Lancez rdairplay et le cart Test et appréciez

Problèmes connus

libqt3-headers nécessaire pour les HotKeys : comme l’a remarqué Luigino Bracci ce matin, le paquet libqt3-headers est nécessaire pour utiliser la fonction HotKeys.

Coulisses

Comme l’ensemble des projets Tryphon, les sources de ces paquets sont accessibles sur http://projects.tryphon.eu/rivendell2-debian.

Le wiki du projet donne quelques indications pour reconstruire les paquets.